Getting started with Max/Msp plugins

Discussion of I-CubeX applications and use. Post here questions about your project, product suggestions, bugs, setup issues, ..

Moderator: Tech

Post Reply
Posts: 3
Joined: Tue Apr 28, 2009 2:45 pm
I-CubeX gear: System

Getting started with Max/Msp plugins

Post by ifrac »

Hi, I am attempting to get started in Max/msp with the iCube and oCube objects.
Working off the Tutorial 1 patch, I am trying to get the digitizer and plugins communicating and two messages are needed but I am only getting some "iCube . ID=0" messages (and also an "oCube . ID=0" ) displaying in the Max window. Clicking the "0 reset" does not produce the desired "I-Cube[0] Reset" message.

The iCube.mxo and oCube.mxo are both in the max-startup folder, which is the specified path in file preferences. The fastlane Usb MIDI interface is set up in MIDI Setup (version 2.1.1) connecting to and from Port A to the iCubeX Digitizer. The "midiin" object in the Max/Msp patch is set to receive the iCubeX Digitizer on this port. I have tried "midiout" to be set to the AU DLS synth and also the iCubeX Digitizer, but neither changes the outcome.

I have tested that the digitizer and the computer are successfully communicating through the iCubeX editor. None of the reference material that I have read specifies how, (if at all) the editor software is to be used to help get the Max plugins working. As I understand it, the digitizer should be configured to ‘Host mode’ to operate from within Max, so the editor software must be used to select this? However, choosing ‘Host mode’ still does not produce the desired "I-Cube[0] Reset" message once the "0 reset" is clicked in the max patch.

Incidentally, if the editor is launched and in ‘Stand Alone mode’ a repeating "I-Cube(0) samp.interval=100" messages appears in the Max window. I am also wondering if the Midi Thru setting in the editor has any bearing? I have tried it on, and off, but again, neither changes the outcome.

I am using Max/Msp 4.6.2, the iCube plugins folder reads "icube-plugins-210-i386", the iCubeX Editor is version 3 and I am using a MacBook Pro running Tiger 10.4.11.

Any suggestions PLEASE!,
Many thanks
Posts: 1
Joined: Wed Dec 31, 1969 7:00 pm

Re: Getting started with Max/Msp plugins

Post by John »

I notice the build says it's for Power PC. You might check with support.
Posts: 4
Joined: Sat Apr 21, 2007 2:38 am

Re: Getting started with Max/Msp plugins

Post by kinesphere »


I can see it's been a long time since you wrote about this, but nevertheless, I would like to ask if you found a way round to sort this "max plugin problem" out.
I have the exact same problem and I cannot receive any signal from any input from the digitizer.
I also tried exactly what you did >> editor on or off / with the host mode in the editor / midi thru settings etc etc... but no luck.
I run snow leopard / macBook Pro / Max/MSP 5.1.4.
I would really appreciate any insight...

thanx in advance
Post Reply